The third-party maintenance window has now passed. Our platform is accessible and all services appear to be fully operational at this time. We are currently awaiting final confirmation from our third-party provider. Thank you for your patience.
Posted Jul 31, 2025 - 04:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 31, 2025 - 00:18 UTC
Scheduled
Our third-party data center provider will be performing maintenance today, 31st July, 2025. This maintenance is scheduled to start at 02:00 (UTC+2) and end at 06:00 (UTC+2). While the maintenance window spans four hours, the actual interruption to our services is expected to last approximately 40 minutes within this period.
During the maintenance, customers may experience temporary connectivity issues, inaccessibility of the platform, and all platform services may be temporarily unavailable. Trading will not be paused during this time.
We will provide progress updates as needed on our status page until the maintenance is completed.