Incapsula Downtime
Incident Report for Bitfinex
Resolved
incapsula seems to have fixed the issue and systems are operating as normal. We'll be sure to keep an eye out for any future problems. Thank you for baring with us.
Posted Mar 10, 2016 - 18:01 UTC
Update
For anyone trying to access bitfinex.com, please make sure you have cleared your cache on your browser. You may need to close all windows and restart your browser. If that does not work, please try a different browser. By following these steps, you should be able to reliably connect to bitfinex.com. We will be sure to keep everyone updated on here and on twitter @bitfinex.com.

For those who have persisting issues accessing bitfinex.com we recommend you use the app if possible as it uses the API, not the front end.
Posted Mar 10, 2016 - 15:45 UTC
Monitoring
Incapsula is experiencing downtime which is affecting some users connectivity to Bitfinex. We're currently working on a solution while Incapsula fixes their issues. We'll be sure to keep everyone updated on twitter: @bitfinex and update this page.
Posted Mar 10, 2016 - 14:57 UTC