Slow Web Response
Incident Report for Bitfinex
Resolved
Back to normal.
Posted 11 months ago. May 23, 2016 - 22:51 UTC
Monitoring
Systems returning to normal.
Posted 11 months ago. May 23, 2016 - 22:34 UTC
Investigating
Investigating a server pooling issue that is causing site slowdown for some users.
Posted 11 months ago. May 23, 2016 - 22:19 UTC