Maintenance is still ongoing, and our teams are working around the clock to complete it as quickly as possible. We apologise for the unexpected extended downtime. We are currently addressing a networking issue and taking additional time to ensure all systems are fully stable and operating as expected before reopening.
While we would like to provide a firm ETA, the technical nature of this work makes an exact timeline difficult to guarantee at this stage. Please be assured that all user funds are safe and there are no security concerns; we are prioritising accuracy and safety over speed. Periodic infrastructure maintenance is necessary to maintain reliability and security. We appreciate your continued patience.
Posted Mar 25, 2026 - 19:33 UTC
Update
Our team continues to work on the ongoing maintenance. We are taking extra time to thoroughly validate all systems to ensure a stable return to service. We’ll share a confirmed ETA as soon as possible. Thank you for your continued patience.
Posted Mar 25, 2026 - 17:46 UTC
Update
Maintenance is ongoing and is exceeding the previously communicated timeframe. We are working to complete the process as quickly as possible and will provide an updated ETA as soon as it is available. Thank you for your patience.
Posted Mar 25, 2026 - 15:00 UTC
Update
Our planned maintenance is still in progress and is nearing completion. New ETA will be communicated within the next 60 minutes. Thank you for your patience.
Posted Mar 25, 2026 - 14:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide progress updates as needed.
Posted Mar 25, 2026 - 08:01 UTC
Scheduled
The Bitfinex platform will undergo scheduled maintenance on 25/03/2026 from 08:00 am UTC for approximately six hours. During this window, the platform will be offline, and all services will be unavailable.
During the maintenance period, we will provide progress updates as needed on this status page and the Bitfinex X Account: https://x.com/bitfinex.
Once maintenance is complete, our platform will initially return in view-only mode for five minutes. During this time, customers may cancel any existing orders. Full platform functionality, including trading and other services, will resume five minutes after the platform becomes available.