Slow deposits
Incident Report for Bitfinex
Resolved
Deposit backlog has been cleared and deposit confirmation times are returning to normal.
Posted Dec 11, 2015 - 23:00 UTC
Investigating
Some users are experiencing longer-than-normal deposit times. We are investigating a latency issue.
Posted Dec 11, 2015 - 22:10 UTC