Slow loading times
Incident Report for Bitfinex
Resolved
This incident has been resolved.
Posted 9 months ago. Jun 14, 2016 - 21:49 UTC
Update
There is no lag in the engine so orders remain unaffected.
Posted 9 months ago. Jun 14, 2016 - 15:35 UTC
Investigating
We're currently experiencing slow loading times for bitfinex.com, we're investigating the issue.
Posted 9 months ago. Jun 14, 2016 - 15:32 UTC