Email delivery delays
Incident Report for Bitfinex
Resolved
Normal operation and email delivery.
Posted 3 months ago. Sep 06, 2017 - 23:02 UTC
Monitoring
Emails are being delivered, but some users are still experiencing delays. We thank you for your patience as the system returns to normal operation.
Posted 3 months ago. Sep 06, 2017 - 22:44 UTC
Identified
Confirmation emails are being delayed due to an issue with our bulk email sending service. Apologies for the delays.
Posted 3 months ago. Sep 06, 2017 - 21:32 UTC