The platform is experiencing performance issues.
Incident Report for Bitfinex
Resolved
The platform back to normal operations. We will monitor closely. Apologies for any inconvenience caused.
Posted 3 months ago. Aug 21, 2017 - 13:31 UTC
Update
We expect to return to normal performance within the next 10 minutes. We will update here.
Posted 3 months ago. Aug 21, 2017 - 13:21 UTC
Identified
Please do not submit actions multiple times when you do not see the UI update instantly. Actions are accepted but the UI may not reflect actions instantly.
Posted 3 months ago. Aug 21, 2017 - 13:13 UTC