The platform is under DDoS attack. We are enabling a stricter protection level.
Incident Report for Bitfinex
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 20, 2017 - 15:51 UTC
Update
The attack is ongoing; Most users will be able to use the platform normally though. You may be alerted by a notification from Cloudflare, our DDoS protection service provider that helps fend of the attack.

Rest assured we are doing what we can to keep the platform accessible to our users.

We apologize for the inconvenience this causes.
Posted about 1 month ago. Jun 14, 2017 - 14:01 UTC
Monitoring
The platform is returning to normal operations. We are closely monitoring the the situation
Posted about 1 month ago. Jun 13, 2017 - 13:56 UTC
Update
The platform is under DDoS attack. We are enabling a stricter protection level.
Posted about 1 month ago. Jun 13, 2017 - 13:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jun 13, 2017 - 13:16 UTC