Platform issues
Incident Report for Bitfinex
Resolved
All systems back to normal operations.
Posted 8 months ago. Nov 16, 2016 - 11:29 UTC
Monitoring
Platform is back to normal service. We are monitoring closely.
Posted 8 months ago. Nov 16, 2016 - 09:44 UTC
Investigating
The platform is experiencing issues. We are working hard on returning to normal operations.
Posted 8 months ago. Nov 16, 2016 - 09:41 UTC